High Sierra (OS10.13) Compatibility Notice

At this time, we are advising SoundSoap users not to upgrade to High Sierra (10.13), especially if you use GarageBand or Logic Pro X.  Currently, increased security measures in 10.13 restrict Audio Unit plug-ins from working properly with these programs.  We hope Apple will address this issue quickly in a software update.  There are additional compatibility issues reported from popular audio software and hardware manufacturers - for additional High Sierra compatibility information, please click here.

Feedback and Knowledge Base