Upgrade Questions

Q: What if I don't have an earlier version of SoundSoap installed on my machine any more?

A: The SoundSoap 3 upgrade does not require you have an earlier version of SoundSoap installed or authorized on your machine.  All you need is the email address your earlier version of SoundSoap is registered to.  If you aren't sure, please contact us using the "Contact support" link on the right and we can look it up for you.


Q: Does this work on Windows?

A: SoundSoap 3 is currently only available for Mac.  We will have a Windows version available later this year.


 

Feedback and Knowledge Base