BIAS Peak Compatibility (Yosemite & El Capitan)

We are frequently asked about running BIAS Peak on OS 10.9 and later.  At this time, BIAS Peak users have reported using Peak successfully on OS 10.9 but have had major problems on OS 10.10 (Yosemite).  Fortunately, the problems that were present running Peak on OS 10.10 appear to be gone in the new OS 10.11 (El Capitan).

The BIAS Authorization Servers are fully functional and maintained by Soundness.  If you need any assistance with your existing Peak authorizations, please use the "Contact Support" link on the right.  Upgrade pricing for all existing BIAS SoundSoap and SoundSaver customers is also available.

Feedback and Knowledge Base