Paleocastor

My feedback

  1. 81 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Facebook Google
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    25 comments  ·  General Announcements  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    Paleocastor commented  · 

    I finally migrated my early-2008 Mac Pro to Yosemite, then discovered that my copy of Peak LE 5.2.1 wouldn't run on it. (I start it up, the computer says another copy is already running! Then pfft.) I keep a Snow Leopard boot disk around just to be able to run Peak. The structure of the BIAS upgrade page makes it impossible to move to later, better versions -- no way to pay for them. PLEASE resurrect Peak for the newer MacOSes!

Feedback and Knowledge Base